tomato 中编译安装M2Crypto

首先从官网查询到M2Crypto最新版本为0.21.1,其基本需求为:

0.21.1: Python 2.3 or newer m2urllib2 requires Python 2.4 or newer OpenSSL 0.9.7 or newer Some optional new features will require OpenSSL 0.9.8 or newer SWIG 1.3.28 or newer required for building SWIG 1.3.30 or newer may be required with Python 2.5 or newer and Python 2.4 with Py_ssize_t patches

<p>
  安装SWIG,ipkg install swig即可搞定。
</p>

<p>
  
</p>

<p>
  从<a href="https://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-0.21.1.tar.gz#md5=f93d8462ff7646397a9f77a2fe602d17" target="_blank">这里</a>获取源代码,解压,然后修改setup.py中self.openssl = &#8216;/opt&#8217;
</p>

<p>
  然后python2.7 setup.py install即可编译安装成功!
</p>